Your **definitive** source for quality pre-owned equipment.

Artisan Technology Group
(217) 352-9330 | sales@artisantg.com | artisantg.com

**Full-service, independent repair center**
with experienced engineers and technicians on staff.

**We buy your excess, underutilized, and idle equipment**
along with credit for buybacks and trade-ins.

**Custom engineering**
so your equipment works exactly as you specify.

- Critical and expedited services
- In stock / Ready-to-ship
- Leasing / Rentals / Demos
- ITAR-certified secure asset solutions

**Expert team | Trust guarantee | 100% satisfaction**

All trademarks, brand names, and brands appearing herein are the property of their respective owners.

Find the National Instruments PXI-5610 at our website: **Click HERE**
NI RF Signal Generators

This guide explains how to install, configure, test, and begin using NI RF signal generators. For more information, such as RF signal generator features and programming, refer to the NI RF Signal Generators Help, accessible at Start»All Programs»National Instruments»NI-RFSG»Documentation.

Refer to the specifications document that ships with your device for detailed specifications.

For the most current versions of documentation, visit ni.com/manuals. For the most current example programs, visit ni.com/instruments. For the latest version of NI-RFSG, visit ni.com/rf.

Contents

Conventions ............................................................................................ 2
1. Verifying System Requirements ......................................................... 4
2. Unpacking ........................................................................................... 4
3. Verifying Kit Contents........................................................................ 4
4. Installing the Software ........................................................................ 6
   Install Application Development Software...................................... 6
   Install the NI-RFSG Instrument Driver ........................................... 6
   Install Toolkits or Add-On Software ............................................... 7
5. Installing the Hardware ....................................................................... 7
   NI 567x ............................................................................................ 7
   Choose a PXI Slot Location ............................................................ 7
   Install the Upconverter Module ....................................................... 8
   Install the AWG Module .......................................................... 9
   NI 565x ............................................................................................ 9
   Cooling............................................................................................. 11
6. Interconnecting NI 567x Modules....................................................... 11
7. Configuring the NI 567x in MAX....................................................... 14
   Rename Both Modules.............................................................. 14
   Associate an NI 54xx AWG Module ............................................. 15
Generate a Signal Using the NI 567x RF Signal Generator
Test Panel ................................................................. 15
8. Configuring the NI 565x in MAX ........................................ 16
Generate a Signal Using the NI 565x RF Signal Generator
Test Panel ................................................................. 17
9. Programming the RF Signal Generator .......................... 18
   NI-RFSG Instrument Driver ......................................... 18
   NI-RFSG Examples .................................................. 19
Appendix A: Hardware Front Panel Connectors and Indicators ..... 20
   NI 5610 RF Upconverter Module .................................. 20
   NI 54xx AWG Module .............................................. 22
   NI 565x RF Signal Generator Module ........................... 24
Appendix B: Building a Basic NI-RFSG Application ............... 25
Appendix C: Troubleshooting ........................................... 30
   Module Front Panel ACCESS LED is Off
   When PXI Chassis is On ........................................... 30
   Hardware Module Does Not Appear in MAX .................. 30
   Module Fails the Self-Test ......................................... 31
   Thermal Shutdown Error ........................................... 31
   Performance Issues Using A MXI Connection ................ 32
Technical Support and Professional Services .......................... 32

Conventions

The following conventions are used in this manual:

»  The » symbol leads you through nested menus to a final action. The sequence File»Page Setup»Options directs you to pull down the File menu, select the Page Setup item, and select Options from the last dialog box.

♦  The ♦ symbol indicates that the following text applies only to a specific product, a specific operating system, or a specific software version.

💡  This icon denotes a tip, which alerts you to advisory information.

📝  This icon denotes a note, which alerts you to important information.

⚠️  This icon denotes a caution, which advises you of precautions to take to avoid injury, data loss, or a system crash.

🌡  When symbol is marked on a product, it denotes a component that may be hot. Touching this component may result in bodily injury.

AWG  Arbitrary Waveform Generator—refers to the NI-RFSG-supported arbitrary waveform generator hardware module used in NI 567x devices.
**bold**

Bold text denotes items that you must select or click in the software, such as menu items and dialog box options. Bold text also denotes parameter names.

**italic**

Italic text denotes variables, emphasis, a cross-reference, or an introduction to a key concept. Italic text also denotes text that is a placeholder for a word or value that you must supply.

**module**

Refers to the NI 565x hardware, or to one of the two hardware components of the NI 567x RF signal generator: the AWG PXI module or the upconverter PXI module.

**monospace**

Text in this font denotes text or characters that you enter from the keyboard. This font is also used for the proper names of paths, directories, programs, functions, operations, variables, and filenames.

**monospace italic**

Italic text in this font denotes text that is a placeholder for a word or value that you must supply.

**MXI**

Multisystem Extension Interface, a high-speed serial interface bus designed to connect computers to PXI, or to connect multiple PXI chassis. In this document, MXI refers to NI MXI-3, MXI-4, or MXI-Express systems.

**NI 54xx**

NI 54xx refers to the AWG module included with the NI 5610 upconverter module to make up the NI 567x. Supported AWG modules include the NI PXI-5421 and NI PXI-5441.

**NI 565x**

NI 565x refers to the NI PXI-5650, NI PXI-5651, or NI PXI-5652 RF signal generators. These devices consist of a single PXI hardware module.

**NI 567x**

NI 567x refers to the NI PXI-5670 or NI PXI-5671 RF signal generators. The NI 567x instruments are comprised of an upconverter hardware module, an AWG hardware module, and the NI-RFSG instrument driver. There is no single physical device labeled “NI PXI-5670” or “NI PXI-5671.”

**Platform**

Text in this font denotes a specific platform and indicates that the text following it applies only to that platform.

**PLL**

Phase-Locked Loop—an electronic circuit that controls an oscillator so that the circuit maintains a constant phase angle relative to a reference signal.

**RF**

Radio Frequency—refers to the signal output from the RF OUTPUT connector on the RF signal generator device front panels.

**upconverter**

A device that frequency-translates IF signals to center around a specified RF frequency—refers to an NI 5610 2-slot RF upconverter hardware module.
1. Verifying System Requirements

Your system must meet certain requirements to use NI RF vector signal generators. For more information on minimum system, recommended system, and supported application development environments (ADEs), refer to the *NI-RFSG Instrument Driver Readme*, which is available on the NI-RFSG CD.

After you install NI-RFSG, you can access the *NI-RFSG Instrument Driver Readme* at Start»All Programs»National Instruments»NI-RFSG»Documentation.

2. Unpacking

RF signal generator hardware modules ship in antistatic packages to prevent damage from electrostatic discharge (ESD). Because ESD can damage several components of the RF signal generator, store all RF signal generator hardware modules in the antistatic envelopes when not in use.

⚠️ **Caution**  Never touch exposed connector pins.

To avoid damage when handling RF signal generator hardware modules, take the following precautions:

- Ground yourself using a grounding strap or by touching a grounded object.
- Touch the antistatic package to a metal part of the computer chassis before removing the hardware module from the package.

Remove each hardware module from the package and inspect it for loose components or any signs of damage. Notify NI if either hardware module appears damaged in any way. Do not install a damaged module into the system.

3. Verifying Kit Contents

Verify that the kit contains the following items required to set up and use the NI RF signal generator:

- CD, which installs the following software components:
  - NI-RFSG instrument driver, including NI-RFSG examples.
  - Hardware and software electronic documentation:
    - *NI RF Signal Generators Help* (online help)
    - *NI RF Signal Generators Getting Started Guide* (PDF)
Specifications documents for your device (PDF)
Hardware user manual for your device (PDF)

Other included documents:
- The specifications document for your RF signal generator
- *NI RF Signal Generators Getting Started Guide* (this document)
- *Read Me First: Safety and Radio-Frequency Interference*
- *Maintain Forced-Air Cooling Note to Users*

Either an NI 567x or NI 565x device. The components for each device are described in Tables 1 and 2, respectively.

**Table 1. NI 567x Required Parts Inventory and Replacement Part Numbers**

<table>
<thead>
<tr>
<th>Hardware Component</th>
<th>Replacement Part Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Two hardware modules:</td>
<td></td>
</tr>
<tr>
<td>• NI 5610 wideband RF upconverter module</td>
<td>189718D-01</td>
</tr>
<tr>
<td>• NI 5421 or NI 5441 AWG module</td>
<td></td>
</tr>
<tr>
<td>Two semi-flexible SMA-to-SMB coaxial cables</td>
<td>190846A-01</td>
</tr>
<tr>
<td>1/8-in. combination Phillips/flathead screwdriver</td>
<td>772006-01</td>
</tr>
<tr>
<td>Plastic collars (cable wrenches) for gripping the coaxial cable hex connectors</td>
<td>746016-01</td>
</tr>
<tr>
<td>NI PXI-1042 chassis with controller (not included)</td>
<td>188079B-01</td>
</tr>
<tr>
<td>100 N-cm SMA torque wrench (not included)</td>
<td>N/A</td>
</tr>
</tbody>
</table>
4. Installing the Software

This section describes the software installation process for NI RF signal generators.

**Install Application Development Software**

You can create applications for RF signal generators using application development environments (ADE) such as LabVIEW, LabWindows™/CVI™, or other development environments.

If you have not already installed an ADE, follow the instructions in the product documentation to install your ADE now.

**Install the NI-RFSG Instrument Driver**

Complete the following steps to install the contents of the *NI-RFSG* CD:

1. Insert the *NI-RFSG* CD. The NI-RFSG installer should open automatically. If not, select **Start**»**Run**, and enter `x:\setup.exe`, where `x` is the letter of the CD drive.

2. Follow the instructions in the installation prompts to complete the NI-RFSG installation. For troubleshooting and operating system-specific instructions, refer to the Hardware Installation Wizard at [ni.com/support/install](http://ni.com/support/install).

   *(Windows Vista)* Users may see access and security messages during installation. Accept the prompts to complete the installation.

3. When the installer completes, a dialog box appears that asks if you want to restart, shut down, or restart later. Select **Restart**.

<table>
<thead>
<tr>
<th>Table 2. NI 565x Required Parts Inventory and Replacement Part Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Hardware Component</strong></td>
</tr>
<tr>
<td>NI PXI-5650</td>
</tr>
<tr>
<td>NI PXI-5651</td>
</tr>
<tr>
<td>NI PXI-5652</td>
</tr>
<tr>
<td>1/8-in. combination Phillips/flathead screwdriver</td>
</tr>
<tr>
<td>NI PXI-1042 chassis with controller (not included)</td>
</tr>
<tr>
<td>100 N-cm SMA torque wrench (not included)</td>
</tr>
</tbody>
</table>
Install Toolkits or Add-On Software

Optional add-on software, such as the Modulation Toolkit, extends the generation capability of NI RF signal generators for modulation-domain and frequency-domain applications. Install any toolkits or add-on software you intend to use with the RF signal generator after installing the *NI-RFSG* CD.

**Note** You must install the NI-RFSG instrument driver before installing the Modulation Toolkit add-on software in order to properly install the Modulation Toolkit examples for NI-RFSG. If the Modulation Toolkit is already installed, repeat or repair the Modulation Toolkit installation after installing NI-RFSG.

5. Installing the Hardware

NI PXI modules are sensitive instruments that should be handled carefully. Do not expose the module to temperatures or humidity beyond the rated maximums. Keep the module free of dust by cleaning with compressed air only. Do not clean the module with any solvents or liquids. For more information about module cooling, refer to the guidelines in the *Maintain Forced-Air Cooling Note to Users* included with the NI RF signal generator.

**NI 567x**

Choose a PXI Slot Location

Installation of the NI 567x hardware requires three vacant PXI slots—two slots for the NI 5610 upconverter module and one slot for the NI 54xx AWG module. The NI 54xx AWG module must be installed in the adjacent slot immediately to the right of the NI 5610 upconverter module to allow use of the included SMA-to-SMB coaxial cables.

The NI 5610 upconverter module onboard frequency reference can drive the PXI backplane clock *only* if the upconverter module is installed in PXI Slot 2. When the NI 5610 is installed in PXI Slot 2, you can configure it to lock the PXI backplane to the NI 5610 onboard oven-controlled crystal oscillator (OCXO) or to an external frequency source (connected to the REF IN connector on the NI 5610 module front panel).
Install the Upconverter Module

Install the NI 5610 RF upconverter module by completing the following steps:

1. Verify that NI-RFSG is installed on your system.
2. Power off the PXI chassis.
3. Insert the NI 5610 upconverter module as shown in Figure 1. This module requires two vacant PXI slots.

**Note** The NI 5610 must be installed in PXI Slot 2 to optionally drive the PXI backplane with the NI 5610 onboard OCXO or an external reference signal.

   a. Remove the black plastic protectors from the four captive screws in the module front panel.
   b. Slide the NI 5610 into an available PXI slot until the ejector handle locks in the upward position.
   c. Tighten the four screws in the module front panel.

---

**Figure 1.** Install the NI 5610 Upconverter Module

| 1 | PXI Chassis |
| 2 | Rubber Screw Covers |
| 3 | NI 5610 Upconverter Module |
| 4 | Ejector Handle in Down Position |
**Install the AWG Module**

Install the NI 54xx AWG module by completing the following steps:

1. Ensure that the PXI chassis is powered off.

2. Install the NI 54xx AWG module by completing the following steps:
   a. Remove the black plastic protectors from the two captive screws in the module front panel.
   b. Slide the NI 54xx AWG module into the slot immediately to the right of the NI 5610 upconverter module. Press firmly until the ejector handle locks in the upright position.
   c. Tighten both screws in the NI 54xx AWG module front panel.

Continue with the procedure in section 6. Interconnecting NI 567x Modules.

**NI 565x**

You can install the NI 565x RF signal generator in any PXI slot marked with a peripheral slot compatibility glyph (a circle containing the slot number).

To install the NI 565x, complete the following steps:

1. Power off and unplug the PXI chassis before installing a PXI device.
2. If the PXI chassis has multiple fan speed settings, ensure that the fans are set to high.
3. Position the PXI chassis so that inlet and outlet vents are not obstructed. For more information, refer to the chassis documentation.
4. Ensure that the ejector handle is in the unlatched (downward) position.
5. Holding the device by the ejector handle, slide it into an empty slot, ensuring that the base card (the card on the left when you look at the front of the device) engages with the card guides in the chassis, as shown in Figure 2.

6. Slide the device completely into the chassis and latch by pulling up on the ejector handle.

7. Tighten the captive screw at the top of the device front panel. Performance may suffer if the screw is not tightened properly.

8. Verify that the PXI chassis fans are operable and free of dust and other contaminants restricting airflow.

9. Before operating the device, cover all empty PXI slots using blank PXI filler panels.

10. Plug in and power on the PXI chassis.
Cooling

When installing the hardware, refer to the guidelines in the Maintain Forced-Air Cooling Note to Users included with the NI RF signal generator to ensure that the device can cool itself effectively.

⚠️ Caution

Inadequate air circulation could cause the temperature inside the chassis to rise above the optimal operating temperature for the RF signal generator, potentially causing thermal shutdown, shorter lifespans, or improper performance.

♦ NI 567x

Under conditions of proper air flow and 25 °C (63 °F) ambient temperatures, the NI 5610 upconverter module operates at internal temperatures of approximately 45 °C (113 °F), the NI 5421 module at approximately 51 °C (124 °F), and the NI 5441 module at approximately 58 °C (136 °F).

♦ NI 565x

Under conditions of proper air flow and 25 °C (63 °F) ambient temperatures, the NI 565X operates at internal temperatures of approximately 38 °C (100 °F).

🔥 Hot Surface

If the RF signal generator has been in use, it may exceed safe handling temperatures and cause burns. Allow the RF signal generator to cool before removing it from the PXI chassis.

💡 Tip

NI recommends that you install PXI slot blockers between the RF signal generator and adjacent hardware modules to maximize cooling air flow. The PXI Chassis Slot Blocker Kit, part number 778678-01, is available for purchase at ni.com.

If you are setting up an NI 565x signal generator, proceed to section 8. Configuring the NI 565x in MAX.

6. Interconnecting NI 567x Modules

The NI 567x hardware modules interconnect through the front panels. Complete the following steps to interconnect the NI 567x hardware module front panel connectors as shown in Figure 3.

1. Connect the INPUT connector on the NI 5610 upconverter module to the CH 0 connector on the NI 54xx AWG module.
2. Connect the TO AWG CLK IN connector on the NI 5610 upconverter module to the CLK IN connector on the NI 54xx AWG module.
**Note**  Published NI 567x RF signal generator specifications assume use of the included cables. Substituting different cables may affect performance.

![Proper NI 567x Front Panel Interconnection](image_url)

**Figure 3.** Proper NI 567x Front Panel Interconnection
3. Carefully tighten all SMA connectors to 100 N-cm using an SMA torque wrench (not included), as shown in Figure 4. Tighten only until the wrench clicks.

*Note* Incorrect torque at SMA connections can degrade signal fidelity, PLL performance, and insertion loss. Use an SMA torque wrench to ensure all SMA connections are properly torqued to 100 N-cm.

![Figure 4. Torque All SMA Connectors to 100 N-cm](image-url)
4. Power up the PXI chassis and controller system.

5. Verify that the ACCESS LEDs on both modules are illuminated. If the LEDs are not illuminated, refer to Appendix C: Troubleshooting.

7. Configuring the NI 567x in MAX

Use Measurement & Automation Explorer (MAX) to configure your National Instruments hardware. MAX informs other programs about which devices reside in the system and how they are configured. MAX is automatically installed with the NI-RFSG driver.

**Note** MAX treats the NI 5610 upconverter module and the NI 54xx AWG module as separate but associated devices. The MAX association is necessary for transparent operation of both modules as a single instrument (the NI 567x) using the NI-RFSG driver.

To use MAX to configure, self-test, associate, and generate signals with the NI 567x, complete the following steps:

1. Launch MAX by navigating to Start>All Programs>National Instruments>Measurement & Automation or by clicking the MAX desktop icon.

2. In the Configuration pane, double-click Devices and Interfaces to see the list of installed devices.

3. Expand the NI-DAQmx Devices folder. You will see a list of installed devices that includes the NI PXI-5610 upconverter module and an AWG module.

**Note** If you do not see both the NI PXI-54xx AWG module and the NI PXI-5610 upconverter module listed, refer to Appendix C: Troubleshooting.

**Rename Both Modules**

MAX allows you to rename both NI 567x hardware modules. The MAX name is used in software to operate the NI 567x hardware resources. You do not have to change the module names from the default, but doing so can make programming easier.

To rename both NI 567x hardware modules, complete steps 4 through 10. If you do not wish to rename the modules, skip to step 11.

4. Right-click the NI 5610 upconverter module and select Rename from the shortcut menu.

5. Enter the new name for the NI 5610 upconverter module.

**Note** The device must consist only of alphanumeric and underscore characters.
6. Click OK.
7. Right-click the AWG module and select Rename from the shortcut menu.
8. Enter the new name for the AWG module.
9. Click OK.
10. Verify that the new names for both modules are displayed before proceeding to step 11.

**Associate an NI 54xx AWG Module**

You must create a MAX association between the NI 5610 upconverter module and the NI 54xx AWG module to control both hardware modules as a single RF signal generator. Complete steps 11 through 13 to make this association.

11. Right-click NI PXI-5610 and select Properties.
12. In the NI 5610 Device Properties dialog box, use the drop-down listbox to specify the NI 54xx AWG module that is connected to the NI 5610 by front panel coaxial cables. Refer to section 6. Interconnecting NI 567x Modules for more information.

**Tip** If you rename the NI 54xx AWG module after association, you must repeat the association. Association between NI 567x hardware modules is lost when a previously associated AWG module is renamed.

13. Click OK to close the dialog box.

**Generate a Signal Using the NI 567x RF Signal Generator Test Panel**

To verify your device configuration, use the NI-RFSG test panel in MAX to generate a simple signal using the RF signal generator hardware. The NI-RFSG test panel tests both NI 567x hardware modules as a single instrument. Complete steps 14 through 19 to use the RF signal generator test panel.

**Note** This test requires front panel interconnection, as shown in Figure 3, and the association of an NI 54xx AWG module with the NI 5610 upconverter module as described in steps 11 through 13.

14. Right-click the NI PXI-5610 upconverter module and select Test Panels.
15. In the NI PXI-567x tab of the Test Panels dialog box, specify a frequency and a power level for signal generation.
Caution  Running the test panel outputs a signal from the RF OUTPUT front panel connector. Disconnect any equipment that can be damaged by the test signal prior to running the test panel.

16. The test panel allows you to verify that the device is operating properly. Click Start to begin signal generation. During signal generation the ACTIVE LEDs on both NI 567x hardware modules are activated.

Note  If either ACTIVE LED does not illuminate or if the RF signal generator test panel generates an error, refer to Appendix C: Troubleshooting.

17. Click Stop to stop waveform generation.
18. Click Close to return to MAX.
19. Exit MAX.

You have completed setup, configuration, and testing of the NI 567x RF Signal Generator.

8. Configuring the NI 565x in MAX

Use Measurement & Automation Explorer (MAX) to configure your National Instruments hardware. MAX informs other programs about which devices reside in the system and how they are configured. MAX is automatically installed with the NI-RFSG driver.

To use MAX to configure, self-test, associate, and generate signals with the NI 565x, complete the following steps:
1. Launch MAX by navigating to Start»All Programs»National Instruments»Measurement & Automation or by clicking the MAX desktop icon.
2. In the Configuration pane, double-click Devices and Interfaces and expand the NI-DAQmx Devices folder. You will see a list of installed devices that includes the NI PXI-565x RF signal generator module.
3. Check that your device appears under Devices and Interfaces. If your device does not appear, press <F5> to refresh the view in MAX. If the NI 565x is still not recognized, refer to ni.com/support/install.

Note  If you are using a MXI interface to control a PXI chassis and encounter performance or initialization issues, refer to your MXI documentation to ensure that the MXI interface is properly set up. Software optimization might be necessary. For MXI-3 optimization, select Start»All Programs»National Instruments MXI-3»MXI-3 Optimization. MXI-4 optimization is performed automatically by the MXI-4 hardware.
4. Perform a device self-test to verify installation by right-clicking the NI 565x device and selecting **Self-Test**. A dialog box appears and indicates whether the device passed the test. When the self-test finishes, a message indicates successful verification or if an error occurred. If an error occurs, refer to ni.com/support/install for troubleshooting information.

5. Record the device number or device name assigned to the device. You need this number when programming the device. The assigned device name is appended to the device in its configuration tree label. For example, after installing the NI 565x, the device configuration tree label may appear as **NI PXI-565X: ”Dev1”**, where Dev1 is the device name. When developing your application, the resource name for your device is the device name MAX assigned to the device.

Note: You can rename NI-DAQmx devices by right-clicking the device and selecting **Rename**.

**Generate a Signal Using the NI 565x RF Signal Generator Test Panel**

To verify your device configuration, use the NI-RFSG test panel in MAX to generate a simple signal using the NI 565x RF signal generator hardware. Complete steps 1 through 6 to use the RF signal generator test panel.

1. Right-click the NI PXI-565x RF signal generator module and select **Test Panels**.

2. In the Test Panels dialog box, specify a frequency and a power level for signal generation.

Caution: Running the test panel outputs a signal from the RF OUTPUT front panel connector. Disconnect any equipment that can be damaged by the test signal prior to running the test panel.

3. The test panel allows you to verify that the NI 565x device is operating properly. Click **Start** to begin signal generation. During signal generation the ACTIVE LED on the NI 565x hardware module is activated.

Note: If the LED does not illuminate or if the RF signal generator test panel generates an error, refer to **Appendix C: Troubleshooting**.

4. Click **Stop** to stop waveform generation.

5. Click **Close** to return to MAX.

6. Exit MAX.
You have completed setup, configuration, and testing of the NI 565x RF Signal Generator.

9. Programming the RF Signal Generator

You can generate signals with the NI RF signal generator using the NI-RFSG instrument driver. You also can run the NI-RFSG examples to demonstrate the functionality of the RF signal generator.

NI-RFSG Instrument Driver

The NI-RFSG driver configures and operates the RF signal generator hardware, performs waveform programming and generation, and basic modulation tasks using LabVIEW VIs or LabWindows/CVI functions. In the case of NI 567x RF signal generators, the NI-RFSG instrument driver transparently operates the NI 5610 upconverter module and the NI 54xx AWG module as a single instrument.

Optional add-on software available from NI, including the Modulation Toolkit and the Spectral Measurements Toolkit, extends the capability of NI RF signal generators to include additional modulation-domain and frequency-domain tasks. The RF signal generator hardware-software architecture is shown in Figure 5.

![Figure 5. RF Signal Generator Hardware-Software Architecture](image-url)
NI-RFSG includes several example applications for both LabVIEW and LabWindows/CVI. These examples serve as interactive tools, programming models, and building blocks in your own applications. For more information on NI-RFSG examples and locations, refer to the *NI-RFSG Instrument Driver Readme*, which is available on the NI-RFSG CD.
Appendix A: Hardware Front Panel Connectors and Indicators

This appendix describes the connectors and LED indicators on the front panels of both NI RF signal generator hardware modules. All inputs and outputs are AC-coupled.

NI 5610 RF Upconverter Module

The NI 5610 RF upconverter module front panel contains six connectors and two multicolor LEDs, as shown in Figure 6.

![NI 5610 Upconverter Module Front Panel](image)

Figure 6. NI 5610 Upconverter Module Front Panel
### Table 3. NI 5610 RF Upconverter Module Front Panel Connectors

<table>
<thead>
<tr>
<th>Connector</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 MHz OUT (TO AWG CLK IN)</td>
<td>Output terminals for replications of the upconverter 10 MHz frequency reference signal, which is useful for driving other devices. Each replication is 180° out-of-phase with the other. The output signal at these connectors is always on and cannot be disabled. Connect the TO AWG CLK IN connector to the CLK IN connector on the NI 54xx module front panel.</td>
</tr>
<tr>
<td>10 MHz OUT</td>
<td></td>
</tr>
<tr>
<td>REF IN</td>
<td>Routes an external frequency reference signal that can be propagated to the PXI backplane. The NI 5610 can lock to this signal.</td>
</tr>
<tr>
<td>IF INPUT</td>
<td>Routes the IF signal from the NI 54xx AWG module for frequency translation. Connect to the CH 0 output on the NI 54xx front panel.</td>
</tr>
<tr>
<td>LOCAL OSC OUT 0</td>
<td>Output terminal for the auxiliary local oscillator signal.</td>
</tr>
<tr>
<td>RF OUTPUT</td>
<td>Output terminal for the upconverted signal at the requested RF frequency.</td>
</tr>
</tbody>
</table>

### Table 4. NI 5610 RF Upconverter Module Front Panel LEDs

<table>
<thead>
<tr>
<th>LED</th>
<th>Indications</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCESS</td>
<td>Indicates the basic hardware status of the NI 5610 module. This LED functions identically to the ACCESS LED on the AWG module front panel.</td>
</tr>
<tr>
<td></td>
<td>OFF—The module is not yet functional or has detected a problem with a PXI power rail.</td>
</tr>
<tr>
<td></td>
<td>AMBER—The module is being accessed.</td>
</tr>
<tr>
<td></td>
<td>GREEN—The module is ready to be programmed.</td>
</tr>
<tr>
<td>ACTIVE</td>
<td>Indicates the status of the NI 5610 PLLs.</td>
</tr>
<tr>
<td></td>
<td>OFF—The module is in an uninitialized state; there is no error.</td>
</tr>
<tr>
<td></td>
<td>AMBER—The module PLLs are attempting to lock.</td>
</tr>
<tr>
<td></td>
<td>GREEN—The module is in a ready state; applicable PLLs are locked and the reverse power protection circuit is closed.</td>
</tr>
<tr>
<td></td>
<td>RED—The module has detected an error state; this state may indicate an overload (reverse power protection circuit is open), lock failure in an applicable PLL, a self-test or calibration failure, or a thermal shutdown condition.</td>
</tr>
</tbody>
</table>
NI 54xx AWG Module

The front panel of the NI 54xx AWG module contains four connectors and two multicolor LEDs, as shown in Figure 7.

![Figure 7. NI 54xx AWG Module Front Panel](image)

<table>
<thead>
<tr>
<th>Connector</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>CH 0</td>
<td>Output terminal for an IF waveform for upconversion to the desired RF frequency. Connect to the IF INPUT connector on the NI 5610 front panel.</td>
</tr>
<tr>
<td>CLK IN</td>
<td>Output terminal for the AWG module reference clock signal. Connect to the REF OUT connector on the NI 5610 module front panel.</td>
</tr>
<tr>
<td>PFI 0</td>
<td>Bidirectional SMB connectors. As an input, the PFI terminals can accept a trigger from an external source to start or step through signal generation.</td>
</tr>
<tr>
<td>PFI 1</td>
<td></td>
</tr>
</tbody>
</table>

Table 5. NI 54xx AWG Module Front Panel Connectors
### Table 6. NI 54xx AWG Module Front Panel LEDs

<table>
<thead>
<tr>
<th>LED</th>
<th>Indications</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCESS</td>
<td>Indicates the basic hardware status of the NI 54xx AWG module. This LED functions identically to the ACCESS LED on the NI 5610 upconverter module front panel.</td>
</tr>
<tr>
<td></td>
<td>OFF—The module is not yet functional or has detected a problem with a power rail.</td>
</tr>
<tr>
<td></td>
<td>AMBER—The module is being accessed.</td>
</tr>
<tr>
<td></td>
<td>GREEN—The module is ready to be programmed.</td>
</tr>
<tr>
<td>ACTIVE</td>
<td>Indicates the state of the NI 54xx AWG module.</td>
</tr>
<tr>
<td></td>
<td>OFF—The module is not armed or triggered.</td>
</tr>
<tr>
<td></td>
<td>AMBER—The module is armed and waiting for a Start trigger.</td>
</tr>
<tr>
<td></td>
<td>GREEN—The module has received a Start trigger and is generating a waveform.</td>
</tr>
<tr>
<td></td>
<td>RED—The module has detected an error state; this may indicate PLL unlocking, self-test failure, or calibration failure.</td>
</tr>
</tbody>
</table>
NI 565x RF Signal Generator Module

The NI 565x RF signal generator module front panel contains two connectors and two multicolor LEDs, as shown in Figure 8.

![Front Panel Diagram](image)

**Figure 8.** NI 565x RF Signal Generator Module Front Panel

<table>
<thead>
<tr>
<th>Connector</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>RF OUT</td>
<td>Output terminal for the RF signal at the requested frequency and power level.</td>
</tr>
<tr>
<td>REF IN/OUT</td>
<td>Routes a frequency reference signal to or from the NI 565x. This connector can be configured as an external frequency reference input or as an output for the onboard 10 MHz reference clock.</td>
</tr>
</tbody>
</table>
Appendix B: Building a Basic NI-RFSG Application

Complete the following steps in LabVIEW to build a basic NI-RFSG application for generating continuous sine wave signals:

1. Select Start→All Programs→National Instruments→LabVIEW to launch LabVIEW. The LabVIEW screen appears.
2. Click New, choose Blank VI, and click OK to create a blank VI.
3. Display the block diagram by clicking it or by selecting Window→Show Block Diagram.
6. Create the block diagram shown in Figure 9 by wiring the five VIs on the block diagram in the order in which they appear in the top row of the NI-RFSG Functions palette.

Table 8. NI 565x RF Signal Generator Module Front Panel LEDs

<table>
<thead>
<tr>
<th>LED</th>
<th>Indications</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCESS</td>
<td>Indicates the basic hardware status of the NI 565x module.</td>
</tr>
<tr>
<td></td>
<td>OFF—The module is not yet functional or has detected a problem with a PXI power rail.</td>
</tr>
<tr>
<td></td>
<td>AMBER—The module is being accessed.</td>
</tr>
<tr>
<td></td>
<td>GREEN—The module is ready to be programmed.</td>
</tr>
<tr>
<td>ACTIVE</td>
<td>Indicates the status of the NI 565x.</td>
</tr>
<tr>
<td></td>
<td>OFF—The module is in an uninitialized state; there is no error.</td>
</tr>
<tr>
<td></td>
<td>AMBER—The module PLLs are attempting to lock.</td>
</tr>
<tr>
<td></td>
<td>GREEN—The module is generating a signal; applicable PLLs are locked.</td>
</tr>
<tr>
<td></td>
<td>RED—The module has detected an error state; this may indicate lock failure in an applicable PLL, a self-test or calibration failure, or a thermal shutdown condition.</td>
</tr>
</tbody>
</table>

Figure 9. Basic NI-RFSG Block Diagram
7. Hover the cursor over the **resource name** terminal on the niRFSG Initialize VI and right-click. Select **Create»Control** to create a front panel control where you specify the RF signal generator device name. The **resource name** terminal is shown in Figure 10.

![Resource Name Terminal](image)

**Figure 10.** Resource Name Terminal on niRFSG Initialize VI

8. Hover the mouse tool over the **frequency (Hz)** and **power level (dBm)** terminals of the niRFSG Configure RF VI. These terminals are shown in Figure 11.

![Frequency and Power Level Terminals](image)

**Figure 11.** Frequency and Power Level Terminals on the niRFSG Configure RF VI

9. Right-click each terminal and select **Create»Control** from the shortcut menu to create frequency and power controls as shown in Figure 12.

![Frequency and Power Level Controls](image)

**Figure 12.** Frequency and Power Level Controls on the Block Diagram

10. Display the VI front panel by clicking it or by selecting **Window»Show Front Panel**. Controls are displayed in which you can specify a frequency and power level.

11. In the VI front panel **power level (dBm)** control, enter 0. In the **frequency (Hz)** control, enter **100M** (100 MHz).
12. In the VI front panel **resource name** control, enter the NI 5610 upconverter device name or the NI 565X device name that you specified in MAX (the NI 5610 upconverter module must be associated with an AWG module. Refer to section 8. Configuring the NI 565x in MAX for more information.).

You can control continuous waveform generation using a **Stop** button. A **Stop** button is typically used within a While Loop. This example places a While Loop around the Check Generation Status VI so that signal generation continues and waveform status is continuously checked until you click STOP.

Build a STOP button by completing steps 13 through 17.

13. Display the block diagram by clicking it or selecting **Window» Show Block Diagram**.

14. Select the While Loop on the **Functions» Programming» Structures** palette.

15. Enclose the niRFSG Check Generation Status VI in the While Loop, as shown in Figure 13.

16. Hover the mouse over the While Loop tunnels and select **Replace with Shift Register**.

17. Select the Unbundle by Name primitive on the **Functions» Programming» Cluster & Variant** palette. Place the primitive inside the While Loop.

18. Wire the **error out** terminal of the niRFSG Check Generation Status VI to the Unbundle by Name primitive.

19. Wire the output terminal of the **status** element to the **Loop Condition** terminal of the While Loop using a logical Or gate.

20. Right-click the unused input terminal of the Or gate **Loop Condition** terminal and select **Create» Control** to create a STOP button on the VI front panel. The portion of the block diagram resulting from steps 17 through 20 is shown in Figure 14.

---

**Figure 13.** Enclose niRFSG Check Generation Status VI in the While Loop
Complete steps 21 and 22 to add an error indicator to the VI front panel.

21. Create an error indicator by right-clicking the error out terminal of the niRFSG Close VI and selecting Create » Indicator. The error out terminal is highlighted in Figure 15.

22. Verify that the VI block diagram now looks like the example in Figure 16.
23. Verify that the VI front panel looks like the example in Figure 17.

![Basic Sine Wave Generation VI Front Panel Using NI 567X](image)

**Figure 17.** Basic Sine Wave Generation VI Front Panel Using NI 567X

**Note** Populate the resource name control with the NI 5610 upconverter module name (refer to the Rename Both Modules section for more information) or the NI 565x name specified in MAX.

24. Click the Run icon on the VI taskbar to initiate sine wave generation.

25. Click the VI front panel STOP button to stop sine wave generation.

**Caution** Always stop VI operation using the front panel STOP button you created.

Never stop a VI with the ABORT button on the taskbar. The ABORT button does not free memory resources and leaves hardware and software in an unknown state.

You have successfully generated a continuous sine wave signal using the NI-RFSG driver software and the RF signal generator hardware.
Appendix C: Troubleshooting

Module Front Panel ACCESS LED is Off When PXI Chassis is On

If the ACCESS LED fails to light after you power on the PXI chassis, a problem may exist with the PXI power rails, a hardware module, or the LED.

**Note** The LEDs may not light until the device has been configured in MAX. Before proceeding, verify that the RF signal generator module(s) appear in MAX.

Troubleshoot this issue by completing the following steps:

1. Power off the PXI chassis.
2. Disconnect any signals from the PXI module front panels.
3. Remove any module front panel connections from the RF signal generator hardware module(s).
4. Remove the RF signal generator hardware and inspect for damage. Do not reinstall a damaged device.
5. Reinstall the RF signal generator in different PXI slot(s). Use the procedure detailed in section 5. Installing the Hardware for more information.
6. Power on the PXI chassis.
7. Verify that the RF signal generator module(s) appear in MAX.
8. Reset the RF signal generator module(s) in MAX and perform a self-test. Refer to section 7. Configuring the NI 567x in MAX or 8. Configuring the NI 565x in MAX for information on performing device resets and self-tests in MAX.
9. If either ACCESS LED still fails to light, and failures continue, contact NI technical support or visit ni.com/support.

Hardware Module Does Not Appear in MAX

Use the following procedure if an RF signal generator hardware module does not appear in MAX:

1. In the MAX Configuration pane, click Devices and Interfaces to expand the category.
2. Click NI-DAQmx Devices folder and press <F5> to refresh the list of installed devices.
3. If an RF signal generator module is still not listed, power off the system, ensure that all RF signal generator hardware is correctly installed, and restart the system.
4. Open the Windows Control Panel and select **System»Hardware»Device Manager**. Complete the appropriate step for the setup:
   - If using a PXI controller, verify that a **National Instruments** entry appears in the system device list. Reinstall NI-RFSG and the RF signal generator hardware modules if error conditions are present in the list.
   - If using a MXI-3 controller, right-click **PCI-to-PCI Bridge** and select **Properties** from the shortcut menu to verify that the bridge is enabled.

5. If either module still fails to appear in the MAX **NI-DAQmx Devices** folder, contact NI technical support or visit [ni.com/support](http://ni.com/support).

**Module Fails the Self-Test**

The MAX self-test performs a brief test of device resources. If an RF signal generator hardware module does not pass the self-test, complete the following steps:

1. Reboot the system.
2. Launch MAX and perform the self-test again. If the module still fails the self-test, proceed to step three.
3. Uninstall the NI-RFSG driver software using the Add/Remove Programs option on the Windows Control Panel. Never attempt to uninstall by deleting files.
4. Reinstall NI-RFSG by running `setup.exe` on the NI-RFSG CD.
5. If either module still fails the self-test, contact NI technical support or visit [ni.com/support](http://ni.com/support).

**Thermal Shutdown Error**

The thermal shutdown error appears when device temperatures exceed safe limits. The RF signal generator shuts down until temperatures fall to acceptable levels and you reset the device in MAX.

To re-enable the RF signal generator after thermal shutdown, complete the following steps:

1. Power down the chassis that contains the device.
2. Review the procedure in the section titled *Cooling* and make any necessary adjustments to ensure that the device is effectively cooled.
3. Call `niRFSG_ResetDevice` (NI-RFSG Reset Device VI) or perform a device reset in MAX. The thermal shutdown error continues to be reported until the device has been successfully reset.
Performance Issues Using A MXI Connection

When using a MXI-3 connection to control the PXI chassis, you must run the MXI Optimization Application prior to using the NI signal generator. By default, this application runs automatically when Windows starts. Using a MXI connection without running this application may result in a time exceeded or internal software error, or an initialization, timeout, or performance issue when using an RF signal generator.

For MXI-3 optimization, select Start»All Programs»National Instruments MXI-3»MXI-3 Optimization. MXI-4 optimization is performed automatically by the MXI-4 hardware.

If the MXI software is not installed, refer to the setup instructions included with the MXI kit to install the software from the MXI software CD or National Instruments Driver CD. After installation, you may be required to reboot the computer before using the MXI application.

If you continue to have initialization or performance issues, refer to the MXI documentation included in your MXI kit, or visit NI Technical Support at ni.com/support.

Technical Support and Professional Services

Visit the following sections of the National Instruments Web site at ni.com for technical support and professional services:

- **Support**—Online technical support resources at ni.com/support include the following:
  - **Self-Help Resources**—For answers and solutions, visit the award-winning National Instruments Web site for software drivers and updates, a searchable KnowledgeBase, product manuals, step-by-step troubleshooting wizards, thousands of example programs, tutorials, application notes, instrument drivers, and so on.
  - **Free Technical Support**—All registered users receive free Basic Service, which includes access to hundreds of Application Engineers worldwide in the NI Discussion Forums at ni.com/forums. National Instruments Application Engineers make sure every question receives an answer.

For information about other technical support options in your area, visit ni.com/services or contact your local office at ni.com/contact.
• **Training and Certification**—Visit ni.com/training for self-paced training, eLearning virtual classrooms, interactive CDs, and Certification program information. You also can register for instructor-led, hands-on courses at locations around the world.

• **System Integration**—If you have time constraints, limited in-house technical resources, or other project challenges, National Instruments Alliance Partner members can help. To learn more, call your local NI office or visit ni.com/alliance.

• **Declaration of Conformity (DoC)**—A DoC is our claim of compliance with the Council of the European Communities using the manufacturer’s declaration of conformity. This system affords the user protection for electronic compatibility (EMC) and product safety. You can obtain the DoC for your product by visiting ni.com/certification.

• **Calibration Certificate**—If your product supports calibration, you can obtain the calibration certificate for your product at ni.com/calibration.

If you searched ni.com and could not find the answers you need, contact your local office or NI corporate headquarters. Phone numbers for our worldwide offices are listed at the front of this manual. You also can visit the Worldwide Offices section of ni.com/niglobal to access the branch office Web sites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.
Artisan Technology Group is an independent supplier of quality pre-owned equipment.

Gold-standard solutions
Extend the life of your critical industrial, commercial, and military systems with our superior service and support.

We buy equipment
Planning to upgrade your current equipment? Have surplus equipment taking up shelf space? We’ll give it a new home.

Learn more!
Visit us at artisantg.com for more info on price quotes, drivers, technical specifications, manuals, and documentation.

Artisan Scientific Corporation dba Artisan Technology Group is not an affiliate, representative, or authorized distributor for any manufacturer listed herein.

We’re here to make your life easier. How can we help you today?
(217) 352-9330 | sales@artisantg.com | artisantg.com